Joomla! 3.9.25 Released

Joomla! 3.9.25 Released

Joomla 3.9.25 is now available.

This is a security release for the 3.x series of Joomla which addresses 9 security vulnerabilities and contains more than 40 bug fixes and improvements.

What's in 3.9.25?

Joomla 3.9.25 includes 9 security vulnerability fixes and addresses several bugs, including:

Security Issues Fixed

  • [20210301] Low Severity - Low Impact - Insecure randomness within 2FA secret generation (affecting Joomla! 3.2.0 through 3.9.24)
  • [20210302] Low Severity - Low Impact - Potential Insecure FOFEncryptRandval (affecting Joomla! 3.2.0 through 3.9.24)
  • [20210303] Low Severity - Moderate Impact - XSS within alert messages showed to users (affecting Joomla! 2.5.0 through 3.9.24)
  • [20210304] Low Severity - Moderate Impact - XSS within the feed parser library (affecting Joomla! 2.5.0 through 3.9.24)
  • [20210305] Low Severity - Low Impact - Input validation within the template manager (affecting Joomla! 3.2.0 through 3.9.24)
  • [20210306] Low Severity - Moderate Impact - com_media allowed paths that are not intended for image uploads (affecting Joomla! 3.0.0 through 3.9.24)
  • [20210307] Low Severity - Moderate Impact - ACL violation within com_content frontend editing (affecting Joomla! 3.0.0 through 3.9.24)
  • [20210308] Low Severity - Moderate Impact - Path Traversal within joomla/archive zip class (affecting Joomla! 3.0.0 through 3.9.24)
  • [20210309] Low Severity - Moderate Impact - Inadequate filtering of form contents could allow to overwrite the author field (affecting Joomla! 1.6.0 through 3.9.24)

Bug fixes and Improvements

  • Fix Save as Copy tag #32454
  • Fix published attribute for Tag field #32332
  • Fix batch menu items #32380
  • Stream transport should enable verify_peer_name when possible #16501
  • Optimize the code for rename incorrectly cased files on update #32176
  • Addional PHP 8 improvments #31977 #32374

Visit GitHub for the full list of bug fixes.

Click here for full release information.

We are familiar with the implementation of the upgrade and are currently upgrading multiple sites CONTACT US for a free proposal to update your site.

It's extremely important to keep your Joomla installation, and extensions up to date to minimise the risk of your site being compromised, you should also check that you are not using vulnerable extensions by visiting Joomla! Vulnerable Extensions List.

We manage, maintain, and update hundreds of Joomla sites, to discuss your update and maintenance needs CONTACT US via our online form or submit a ticket on our helpdesk SUBMIT TICKET

Joomla! 3.9.26 Released
Heatmap Integration

Related Posts

By accepting you will be accessing a service provided by a third-party external to https://realvisioninternet.com/